Ubuntu Sleep Foo… Resolved… Kinda…

After a lot of searching, testing, trying stupid stuff, ripping hair out, frustration, and what not, I finally found a hint what is going on here.

To recap you can read here and here or just continue reading.

So, if you didn’t follow the links, then here a quick recap. My machine, after installing a ton of new hardware (new motherboard, processor, cooler, memory, graphics adapter) and re-installing Ubuntu started acting weirdly. It was in standby, when I returned to the office (it is a server!) or some service was not responding (because it was in standby).

After looking at the usual suspects like kernel, drivers, certain pieces of hardware, I first suspected the UPS to cause this. But I never could find a reason for that trigger in the UPS and even without the UPS the problem prevailed.

Afterwards followed a phase where I suspected the desktop environment because XFCE reacted differently than KDE and so on. But digging into this also didn’t resolve anything. But I learned a lot about UPower in the process.

Finally I had the opportunity to see it happen in real time and it was an eye opener. I have a TV and a Blu-Ray player in my home office to be able to watch… okay, listen to a DVD or a Netflix movie. But it never occurred to me that my “random” sleep events always happened when the TV and/or the Blu-Ray player was used.

Conclusion… well, it is not a software problem at all. It is a hardware problem. and now we are dealing with a different kind of problem. Either I have a problem with the electric in my office or, much simpler, my power supply is not strong enough. Remember, that I replaced everything but the power supply?

I guess my next step is to get a new power supply. Which would also help me to get my Windows machine back up and running because I can rotate power supplies… yeah